VPS更新内核失败,提示Error 24的解决办法

Posted by

近来更新vps,总是会遇到错误提示:

Error 24 : Write error : cannot write compressed block

这主要是由于boot分区过小,空间不足引起的,需要删除旧的内核,释放空间,然后重新更新即可。特记录一下几个命令:

查找目前已经安装的内核和正在使用的内核:

uname -a

dpkg -l | grep linux-image

或者

dpkg --get-selections | grep linux

删除指定的内核:

apt-get purge 旧内核

更新grub系统引导
update-grub

有一些内容虽然显示在上面,但在移除时,并不会提示释放多放空间,所以并不会起作用。只要删除掉实际占用空间的旧内核后,才会解决这个问题。

Leave a Reply

您的电子邮箱地址不会被公开。